Facebook Map Submodule Broken in Timeline View

Noticed some weird and unexpected behavior when playing around with Facebook Places and Map view of all the places I’ve been to. Currently, on my timeline, I don’t see any Places-type posts. However, the map submodule on my timeline looks like this:

Image

Right off the bat, you can tell something is wrong for two reasons. 
1. If I had at least one place, it would be shown in the sub-module view, instead of the generic world map that is shown.
2. It incorrectly says that I have 13 places when I know I have a total of ZERO on my timeline.

So, when I click on the sub-module, I am taken to the Map view and I see this: 

Image

Now, this view is how I expect it to be. Zero places just like I thought. So why the discrepancy between the two views?

Let’s try an experiment. Why don’t I add a place I’ve been to?
Image

Now, the Places sub-module in the Timeline view looks like:
Image

So what happened was that the count of 13 was incremented to 14 because I added a place. OK, now what does the Map view look like?

Image

This is expected. Now, I’ve been to one place. So what would happen if I were to delete this place from my timeline?

Image

Here’s where we can see where the strangeness and the bug start to manifest. In the Map submodule on the Timeline page, I would expect the count to go back to 13 — as it was when we started this exercise, but NO! It is still at the new number of 14!!

Image

And when I go an check the Map view, the count is again zero. 

So to summarize, the main Map view works just fine, but the Map submodule in the Timeline view is broken because it does not decrement the counter after you have deleted a place from your timeline.