Schwab Site Has Pre-historic Browser Requirements

When I went to the Charles Schwab site to view retirement plans, I saw something that made me laugh out loud. According to the splash page, their browser requirements are Netscape 4.06 (or higher) or Internet Explorer 4.01 (or higher). 

I don’t know which would be more shocking to me: 

  • If someone actually still uses one of these ancient browsers
  • If their current site is actually usable with one of these ancient browsers

Image